Cuidado con el alimentador que utilizáis con vuestra Raspberry Pi | Algo de Linux

viernes, 9 de febrero de 2018

Cuidado con el alimentador que utilizáis con vuestra Raspberry Pi

Tenía mi vieja Raspberry Pi Model B criando polvo y después de varios intentos de rescatarla, ya casi había decidido darla por muerta...

Es cierto que no le he dedicado mucho tiempo en cada intento, pero venía observando extraños errores después de instalarle algún sistema. Por ejemplo: Conseguía iniciar el sistema operativo instalado, pero la interfaz de red no cogía IP. Por otro lado, conectaba el teclado y para escribir una letra tardaba una vida. El caso es que desconectaba el cable de red y el teclado volvía a escribir sin ningún problema. Como el teclado era inalámbrico, decidí probar a conectar un teclado de cable vía usb y sucedía lo mismo.

Enfin. Hice tantas pruebas que ya no se me ocurría qué más hacer. Lo único que me quedaba por probar era cambiar la fuente de alimentación. Y bingo! Ese era el problema. El alimentador que tenía conectado tan sólo daba 300 mA.

Requisitos de alimentación de cada modelo de Raspberry Pi:
ProductRecommended PSU current capacityMaximum total USB peripheral current drawTypical bare-board active current consumption
Raspberry Pi Model A700mA500mA200mA
Raspberry Pi Model B1.2A500mA500mA
Raspberry Pi Model A+700mA500mA180mA
Raspberry Pi Model B+1.8A600mA/1.2A (switchable)330mA
Raspberry Pi 2 Model B1.8A600mA/1.2A (switchable)350mA
Raspberry Pi 3 Model B2.5A1.2A400mA
Raspberry Pi Zero W1.2ALimited by PSU, board, and connector ratings only.150mA
Raspberry Pi Zero1.2ALimited by PSU, board, and connector ratings only100mA
Fuente: Raspberry Pi FAQs
Publicado por primera vez en http://enavas.blogspot.com.es

2 comentarios:

Alfonso Pastor dijo...

Muy acertado comentarlo, Esteban. Me pasó exactamente lo mismo: la Rasberry Pi Modelo B me empezó a funcionar de forma errática: se colgaba, no arrancaba la mitad de las veces, iba lentísima, se quedaba sin red,... pensé que se había averiado después de varios años de servicio.

Tenía la fuente de alimentación "buena", comprada junto con la Raspberry en farnell.com. Como tú, por hacer una prueba más probé una fuente de alimentación potente (de 2A) de un móvil y ¡voilá! de nuevo funcionando al 100%.

Saludos.

Alfonso Pastor dijo...

Muy acertado comentarlo, Esteban. Me pasó exactamente lo mismo: la Rasberry Pi Modelo B me empezó a funcionar de forma errática: se colgaba, no arrancaba la mitad de las veces, iba lentísima, se quedaba sin red,... pensé que se había averiado después de varios años de servicio.

Tenía la fuente de alimentación "buena", comprada junto con la Raspberry en farnell.com. Como tú, por hacer una prueba más probé una fuente de alimentación potente (de 2A) de un móvil y ¡voilá! de nuevo funcionando al 100%.

Saludos.