WARNING: Security updates for your current Hardware Enablement Stack ended on 2016-08-04 | Algo de Linux

viernes, 7 de octubre de 2016

WARNING: Security updates for your current Hardware Enablement Stack ended on 2016-08-04

Si os habéis conectado mediante ssh a vuestros Ubuntu 14.04 LTS como administrador, habréis visto que muestran un mensaje como el siguiente:
WARNING: Security updates for your current Hardware Enablement Stack
ended on 2016-08-04:
 * http://wiki.ubuntu.com/1404_HWE_EOL
There is a graphics stack installed on this system. An upgrade to a
configuration supported for the full lifetime of the LTS will become
available on 2016-07-21 and can be installed by running 'update-manager'
in the Dash.
En cualquier caso, si no lo habéis visto, siempre podéis ejecutar el siguiente comando para comprobar el estado de vuestro HWE:
# hwe-support-status
Y os preguntaréis: ¿Qué significa ésto? Ubuntu Hardware Enablement Stacks (HWE) es una característica diseñada para proporcionar a una distribución Ubuntu LTS soporte hardware introducido en versiones posteriores de Ubuntu. Para más información os recomiendo echar un vistazo al siguiente artículo del wiki de Ubuntu:

Sabiendo ésto, comprenderéis lo que significa el mensaje: Que el soporte HWE para nuestro Ubuntu 14.04 terminó el 04/08/2016

Si queréis solucionar el problema, tenéis tres opciones:
  1. Actualizar HWE a Ubuntu 16.04 (kernel versión 4.4)
  2. Actualizar a Ubuntu 16.04 LTS
  3. Realizar una instalación desde 0 de Ubuntu 16.04 LTS
Como por el volumen de trabajo es demasiado alto, el curso ha empezado y todo está en marcha, no me parece muy viable ni la segunda ni la tercera opción. Así que he optado por actualizar HWE a Ubuntu 16.04 mediante pkgsync.

Antes de actualizar HWE, determinaremos qué paquetes es necesario actualizar en nuestro sistema:
# hwe-support-status --show-replacements
Y obtendremos una salida similar a la siguiente:
xserver-xorg-lts-xenial linux-generic-lts-xenial linux-image-generic-lts-xenial libgl1-mesa-glx-lts-xenial libwayland-egl1-mesa-lts-xenial
Esto quiere decir que tendremos que instalar esos paquetes en nuestro sistema.

¿Y cómo lo hacemos? 
  • Incluyendo los nombres de los paquetes "-xenial" indicados en un fichero musthave
    • xserver-xorg-lts-xenial linux-generic-lts-xenial linux-image-generic-lts-xenial libgl1-mesa-glx-lts-xenial libwayland-egl1-mesa-lts-xenial
  • Y quitando los paquetes correspondientes de "-vivid" de los ficheros musthave:
    • xserver-xorg-lts-vivid linux-generic-lts-vivid linux-image-generic-lts-vivid libgl1-mesa-glx-lts-vivid libwayland-egl1-mesa-lts-vivid
Una vez instalados los nuevos paquetes, si ejecutamos:
# hwe-support-status
Comprobaremos que nuestro HWE ha sido actualizado:
Your Hardware Enablement Stack (HWE) is supported until April 2019.
Publicado por primera vez en http://enavas.blogspot.com.es

No hay comentarios: