Módulo puppet para eliminar el mensaje de warning "[puppetmasterd], which is a deprecated section..." | Algo de Linux

miércoles, 31 de octubre de 2012

Módulo puppet para eliminar el mensaje de warning "[puppetmasterd], which is a deprecated section..."

En versiones anteriores de puppet, la sección de configuración del puppetmaster en el fichero /etc/puppet/puppet.conf se llamaba [puppetmasterd]. Ésto ha cambiado y actualmente esta sección se llama [master].

Puppet muestra un warning similar al siguiente:

warning: You have configuration parameter $certname specified in [puppetmasterd], which is a deprecated section. I'm assuming you meant [master]

Para solucionarlo, he creado una tarea de puppet que, haciendo uso de un tipo definido por el usuario llamado replace.pp de David Schmitt cambia [puppetmasterd] por [master] en el archivo /etc/puppet/puppet.conf

https://www.box.com/s/1e33z9l2tpnx630yzfqa

Para que dicho módulo funcione, tenemos que colocar el archivo replace.pp en un directorio: /etc/puppet/defines/ del servidor puppet. Si queréis utilizar la tarea, cread este directorio. En él iremos almacenando funciones interesantes, como la que hemos mencionado anteriormente.