Repositorios debian-multimedia en Debian | Algo de Linux

martes, 9 de marzo de 2010

Repositorios debian-multimedia en Debian

Debian-multimedia es un repositorio no oficial de software Debian mantenido por Christian Marillat que nos proporciona software multimedia como por ejemplo, avidemux, cinelerra, MythTV, entre otras muchas cosas como flash-player, w32codecs, w64codecs, acroread...

http://www.debian-multimedia.org

Para agregarlo a nuestra distribución, descargamos el paquete debian-multimedia-keyring:

# wget http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2008.10.16_all.deb

Y lo instalamos:

# dpkg -i debian-multimedia-keyring_2008.10.16_all.deb

Con esto, conseguiremos tener las claves públicas del mantenedor del repositorio.

Una vez que tenemos instalado el paquete anterior, modificamos nuestro archivo sources.list:

# nano /etc/apt/sources.list

Si tenemos lenny, agregaremos la siguiente línea:

deb http://www.debian-multimedia.org lenny main

Y si queremos además poder instalar software non-free, en lugar de la línea anterior pondremos ésta:

deb http://www.debian-multimedia.org lenny main non-free

Si nuestra distro es squeeze, agregaremos la siguiente línea:

deb http://www.debian-multimedia.org squeeze main

Al igual que en lenny, si queremos además poder instalar software non-free, en lugar de la línea anterior pondremos ésta:

deb http://www.debian-multimedia.org squeeze main non-free

Una vez modificado nuestro /etc/apt/sources.list, hacemos un:

# apt-get update

Y ya tendremos actualizada nuestra lista de paquetes en la que podremos contar con software multimedia.

4 comentarios:

uno más dijo...

Otra opción sería aprovechar el apt y descargar dichas claves a través de él: apt-get install debian-multimedia-keyring

Excelente "chuleta" para los más olvidadizos.

Disfruta.

Anónimo dijo...

Hola hice los pasos la instalacion todo salio ok pero al momento de hacer el update ... me boto lo sgtes errores ...

W: Imposible obtener http://www.debian-multimedia.org/dists/lenny/main/binary-i386/Packages 404 Not Found

W: Imposible obtener http://www.debian-multimedia.org/dists/lenny/non-free/binary-i386/Packages 404 Not Found

E: Algunos archivos de índice no se han podido descargar, se han ignorado,
o se ha utilizado unos antiguos en su lugar.



Alguna idea ? ... Gracias.

Esteban M. Navas dijo...

Parece que hay problemas con los índices de los repositorios.

Alejandrox dijo...

hola antes que nada en el enlace que se debe añadir a /etc/apt/sources.list aparece el nombre de la version debian, en su caso arroja el error y menciona la version "/lenny/" este error es por que el enlace debe llevar la version que usted tiene:

para squeeze sera: "/squeeze/"
para lenny sera: "/lenny/"

intente y ya vera gracias.